Sourcegraph Cloud Executors Not Allowing Batch Changes
Incident Report for Sourcegraph
Resolved
Cloud customers have been upgraded to the latest version which resolves this issue. Customers with persisting issues creating batch changes using executors should reach out to the Sourcegraph support team.
Posted Jan 08, 2025 - 18:17 UTC
Update
Cloud customers that have reported the issue have been patched and the patch has been applied to other cloud customers as well.

If you are reading this and still experiencing the issue please reach out to support@sourcegraph.com immediately.
Posted Jan 08, 2025 - 18:10 UTC
Monitoring
If you are reading this message currently and have already reached out to Sourcegraph Support about this issue please be advised that a fix has been deployed to your instance and Batch Changes should now be working as intended.

If you are reading this and have not reached out to Sourcegraph Support about this issue a fix will be deployed to your instance by Tuesday EOD.
Posted Jan 06, 2025 - 15:15 UTC
Update
A fix has been created and will be rolled out over the weekend and should be rolled out to affected customers by Monday EOD.

Please follow closely for updates.
Posted Jan 03, 2025 - 17:54 UTC
Identified
We've found the root cause of the issue and are currently creating a fix for it. Thank you for your patience and please stay tuned.
Posted Jan 02, 2025 - 23:25 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jan 02, 2025 - 18:19 UTC
This incident affected: Sourcegraph Cloud.