Infrastructure Outage

Incident Report for Sourcegraph

Resolved

This incident has been resolved.
Posted May 16, 2025 - 11:44 UTC

Update

We are continuing to monitor for any further issues.
Posted May 16, 2025 - 09:19 UTC

Monitoring

A workaround has been applied and the services are now online again. We will continue to monitor service health closely
Posted May 16, 2025 - 09:12 UTC

Identified

The issue has been identified as a GCP outage. We are applying a workaround to restore our services
Posted May 16, 2025 - 08:20 UTC

Update

We are continuing to investigate this issue:

- Cody Gateway access is affected, but remains available for workspaces
- Individual workspaces should be accessible but there may be partial outages.
Posted May 16, 2025 - 06:55 UTC

Update

We are continuing to investigate this issue:

- Cody Gateway access is affected
- Individual workspaces should be accessible but there may be partial outages.
Posted May 16, 2025 - 06:54 UTC

Investigating

We are currently investigating an incident with our cloud infrastructure which appears to have failed. Attempts are being made to re-provision the affected services.
Posted May 16, 2025 - 06:45 UTC
This incident affected: Sourcegraph Workspaces, Cody Gateway, and Sourcegraph.com public code search, Cody Free, and Cody Pro.