Issue with GitLab Permissions
Incident Report for Sourcegraph
Resolved
This issue has now been resolved. A patch has been released which should address this issue for on-prem customers and fixes have also been deployed to sourcegraph.com.
Posted May 31, 2022 - 16:20 UTC
Identified
Our Engineering team is currently working on a fix to address this issue. We will communicate further updates as soon it is applied. Thanks for your patience.
Posted May 26, 2022 - 12:09 UTC
Investigating
We have identified an issue that can cause you not to get search results that you would expect or see repositories that have been added to Sourcegraph. You are impacted if you are a Sourcegraph.com user using GitLab.com or an on-prem customer using GitLab version 15.0 or later, or older Gitlab versions that have OAuth access token expiration enabled. Otherwise you are not impacted.

If you are impacted, you can remediate this by removing and re-adding GitLab personal code host connection every two hours (if you are a Sourcegraph.com user) or signing out and in every two hours with GitLab OAuth (if you are an on-prem user).

We are currently working to resolve this issue and regret the inconvenience. We will provide an update when functionality is restored.
Posted May 24, 2022 - 13:11 UTC