Mis-sequenced migration steps when upgrading to 3.35.0
Incident Report for Sourcegraph
Resolved
3.35.1 is now available. When upgrading to 3.35 from any previous version of Sourcegraph, please upgrade to 3.35.1. If you have already upgraded to 3.35.0, please upgrade to 3.35.1. Again, upgrading is the only reliable way to resolve this issue. If you have any questions, email support@sourcegraph.com.
Posted Jan 05, 2022 - 23:04 UTC
Update
We are so close to having 3.35.1 available, but we need a little more time to complete our testing and make sure the patch properly resolves the issue. We should have this ready within another 24 hours from this post (likely much sooner). Unfortunately, upgrading will be the only reliable remediation. We are sorry we cannot offer an alternative remediation option (like the manual steps we mentioned in our last post). As always, if you have any questions, email support@sourcegraph.com.
Posted Jan 04, 2022 - 22:35 UTC
Update
We are still working on a patch for 3.35.1, as well as steps for anyone who has already upgraded to 3.35.0 to take in lieu of upgrading to 3.35.1 (we now anticipate having both ready within 24 hours from this post). Again, if you have not yet upgraded to 3.35, please wait until 3.35.1 is available. We will post again when 3.35.1 and the manual steps to correct migration mis-sequence are ready. If you have any questions in the meantime, email support@sourcegraph.com.
Posted Jan 04, 2022 - 00:01 UTC
Identified
We are aware there is an issue with our 3.35.0 release (for self-hosted customers) where the migration sequence runs out of sequence and causes existing Code Insights to “disappear” (there is a way to restore them). This issue may impact other parts of the product and we are working to verify that. You are impacted if you have upgraded to 3.35.0 from an earlier version of Sourcegraph, otherwise you are not impacted. We are working on a patch for 3.35.1 and recommend you hold-off upgrading to 3.35 until 3.35.1 is available (we anticipate 3.35.1 will be available within 24-48 hours). We are also investigating the remediation steps for any customers who have upgraded and will share those here and via direct email to those customers. If you have any questions, email support@sourcegraph.com.
Posted Jan 03, 2022 - 22:52 UTC