GPT4o and Mistral 8x7b not working for chat
Incident Report for Sourcegraph
Resolved
We think the impact from the issue is over.
Posted Sep 05, 2024 - 22:23 UTC
Update
GPT-4o and Mixtral 8x7B are working again. We will be monitoring before we mark this resolved.
Posted Sep 05, 2024 - 17:10 UTC
Monitoring
Problem: Asking Cody a question using GPT4o or Mistral 8x7b models fails due to a regression caused by a recent update.

Impact: This failure results in errors within VS Code and Cody Web platforms.

Fix: An update is currently being rolled out.
Posted Sep 05, 2024 - 17:00 UTC
Investigating
When Asking Cody a question using GPT4o or Mistral 8x7b models fails with the following errors:

VS Code: "SourcegraphNodeCompletionsClient: isError(parseEvents(bufferText)) Error: invalid completion event"

Cody Web: "Request Failed: Cannot read properties of undefined (reading 'length')"

Please use another model for the meantime.
Posted Sep 05, 2024 - 15:40 UTC
This incident affected: Cody Gateway.