Cody Authentication Issues

Incident Report for Sourcegraph

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 17:39 UTC

Monitoring

A fix has been applied and we are monitoring the situation.
Posted Feb 25, 2025 - 08:15 UTC

Investigating

We're investigating an authentication issue affecting Cody services. Pro and paid users are currently being incorrectly identified as free users, resulting in access limitations and error messages (HTTP 429/403). This issue is impacting both the web interface and IDE integrations. Our engineering team is actively working to resolve this problem and restore proper account recognition. We apologize for the inconvenience and will provide updates as we have more information.
Posted Feb 25, 2025 - 07:28 UTC
This incident affected: Sourcegraph.com public code search, Cody Free, and Cody Pro.